Coffee Shop BLOG
ガレージキット主体の告知用BLOGです。(注) 珈琲を売ってるわけではありません。
FC2カウンター



プロフィール

coffee shop

Author:coffee shop
ディーラー名: coffee shop
管理人: つぶ



カテゴリー



最近の記事



最近のコメント



最近のトラックバック



月別アーカイブ



ブログ内検索



ユーザータグ

宇宙 イベント参加 コンピュータ フルスクラッチ 実演イベント 造型ノウハウ 複製ノウハウ 塗装ノウハウ ヘッドフォン・イヤフォン SuperModelers フィギュア 宮下未紀 WF カメラ 電撃ホビー工房 れでぃ×ばと! HC WHF TAT-CON スキャナ 紙の電子化 計算機科学部 TF 



RSSフィード



リンク

このブログをリンクに追加する



amazon



スポンサーサイト
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。


CS-SkewCheckerの動作要件の更新予告
 お久ぶりです。
MSのこの間のキャンペーンで、PC環境をWin7からWin10にアップデートしました。
Windows10ですがWindowsアップデートが強制的にかかるのが一番の不満ですが、
ゲームとか色々と手を伸ばす余裕がないので、他の不具合と思う箇所に
ぶちあたらなくて済んでるのが幸か不幸なのか……

さて本題。
CS-SkewCheckerの動作要件を変更しようとしています。
想定している要件:
 .Net framework 4.5.2 + Visual C++ 2013 再配布可能パッケージ
 Windows 7以降 64bit版

OS変更ついでにソフトウェアのサポート状況を調査したのですが、
CS-SkewCheckerが利用している .Net framework 4.0 は既に
サポートが終了しており、サポートが続いているのが 4.5.2 or 4.6.1
になっていました。
他、利用ライブラリや開発環境などの関係で
.Net framework 4.5.2 と Visual C++ 2013 再配布可能パッケージ
に変更しようとしております。

また動作環境を切り替える機会に、64bit化への切り替えも検討しました。
ソフトを作り始めた当初は XP全盛で、32bit環境を捨てることは無謀な
選択でしたが、Win7以降だと64bit環境はまま広まってきたんじゃ
ないかなと思っています。
32bit版、64bit版ともに出すのが理想ですが、自分の余力では両方を
メンテし続ける余裕がないため、64bit化するなら 32bitの方を落とす
しかないかなぁと思っています。
64bit版OSの普及度合いは、使っている人に聞いてみないと分からない
のですが、32bit版のみ使っている人はどの位なもんなんでしょう。
ご意見を頂きたい所存です。


次参加予定でのコミティア118では CS-SkewCheckerを持ち込む予定で、
次のように考えています。
1. ver 0.11.1 (32bit版)
2. ver 0.12 (64bit版)

■ 0.11.1 について
これまでの動作要件と同じです。

0.11との差分は以下
機能アップ項目:
1. 白飛ばし機能の改善
 ノベル系や状態の良くて細かいトーンを使用していない同人誌だとあまり
 問題なかったのですが、ラノベの挿絵でトーンが細かいものなど従来方式
 ではなんぎしたものがあったため、3ヶ月くらいかけてリテイクしました。

修正項目:
1. 色除去にて、マウスから色情報を取得しようとするとずれた位置の値を取得してしまう問題を修正
 (クロップしている場合に問題が発生します)
2. モアレ除去を使ったファイル出力で、スクリーン線数の指定を無視していた問題を修正

■ ver 0.12
0.11.1 を 64bit対応したもの +α

64bit対応したアプリケーションは 64bit版OSでしか動きません。
(=32bit版OS上では動作しません)
またランタイムライブラリに、
 .Net framework 4.5.2
 Visual C++ 2013 再配布可能パッケージ (64bit版)
がインストールされている必要があります。

(.Net framewrorkは 4以上だと 4.0, 4.5系統, 4.6系統がありますが、
 このうちどれか一種類のみしかインストールできません。
 一応アッパーコンパチらしいので、サポートが継続されている4.5系、
 ないし4.6系の新しいものを環境に応じて選択しインストールして下さい。

 参考1: Win8 だと 4.5系, Win10だと 4.6系が最初からインストールさ
 れています。
 参考2: 2016/09/26時点では 4.5系が4.5.2、4.6系が 4.6.1 が最新でした。
)

+α分に関しては、使用ライブラリを最新のものにするなど、毛の生えた程度に
なる見込みです。
(というか未だ新しい開発環境への適用作業中で不確定)


この記事に対するコメント


この記事に対するコメントの投稿














管理者にだけ表示を許可する


この記事に対するトラックバック
この記事にトラックバックする(FC2ブログユーザー)
トラックバックURL
→http://coffeeshop4u.blog51.fc2.com/tb.php/211-0a418fe8



上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。